App Not Loading
Incident Report for Sisense for Cloud Data Teams
Postmortem

The following is the incident report for the Sisense incident that occurred on May 28, 2020 from 11:35 AM PST to 11:50 AM PST. This issue specifically affected all customers using the Sisense for Cloud Data Teams web application. These customers were not able to access Sisense for Cloud Data Teams as well as some background work may have been interrupted, delayed or lost during the outage period . We understand the impact this had on our customers and sincerely apologize. We have taken a number of steps to prevent this issue from occurring in the future as detailed further below.

ISSUE SUMMARY

Our investigation into the issue found that the outage occurred when the underlying hardware for one of our databases supporting Sisense for Cloud Data Teams crashed and did not failover for 15 minutes due to an underlying issue with AWS. This caused the web application to go down during this period.

As part of our efforts to rectify the system, the database was restarted and all services were restored. This brought the web application back up and all customers were able to access Sisense for Cloud Data Teams.

REMEDIATION

We are confident that we have identified the necessary corrections and are equipped to handle similar outages in the future. The team is committed to creating the most reliable data platform possible. As a response to this issue, we've made key improvements to our infrastructure:

  • Editing our error reporting verbiage to ensure that internal errors were clearly described

  • Working with our cloud provider to understand and reduce time of impact for hardware failures.

  • Adding better error pages so customers can know how to access support and the status page

For more information, please reach out to our Solutions Team at suppordtt@sisense.com or via live chat.

Posted May 29, 2020 - 15:37 PDT

Resolved
The Sisense application is operational. The Sisense Cloud Support Team can be reached at supportdt@sisense.com or via live chat.
Posted May 28, 2020 - 13:00 PDT
Monitoring
The Sisense application is now loading for all users. Engineers are actively monitoring the issue. The Sisense Cloud Support Team can be reached at supportdt@sisense.com or via live chat.
Posted May 28, 2020 - 12:27 PDT
Identified
The Sisense application is now loading for most users. Engineers are continuing to investigate the issue. The Sisense Cloud Support Team can be reached at supportdt@sisense.com or via live chat.
Posted May 28, 2020 - 12:09 PDT
Investigating
The Sisense application is not loading for some users. Engineers are actively investigating the issue. The Sisense Cloud Support Team can be reached at supportdt@sisense.com or via live chat.
Posted May 28, 2020 - 11:45 PDT
This incident affected: Periscope.